Performance degradation affecting ENEO Prepaid services.

Incident Report for Smobilpay

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 21:05 UTC

Identified

We have identified instability in { ENEO Prepaid) services. We have escalated this to the Service Provider for resolution.
Posted Jun 28, 2025 - 14:19 UTC
This incident affected: Bill Payment (ENEO Bills).