The incident has been resolved. We apologise for the inconvenience.
Posted Mar 04, 2026 - 19:06 UTC
Update
We are still experiencing a major outage with the Orange Money Services, but we are following up closely with the Service Provider and will provide an update as soon as possible. We apologise for any inconvenience caused.
Posted Mar 04, 2026 - 17:04 UTC
Identified
We have identified instability in orange services. We have escalated this to the Service Provider for resolution.