Performance degradation affecting Orange Merchand Services.

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Oct 09, 2025 - 11:28 UTC

Identified

We have identified instability in Orange Merchand services. We have escalated this to the Service Provider for resolution.
Posted Oct 09, 2025 - 06:53 UTC
This incident affected: Cameroon MNO Services (Orange Money : Collections, Orange Money : Disbursement).