Performance degradation affecting Orange Money service.

Incident Report for Smobilpay

Resolved

This incident has been resolved. We apologise for any inconvenience caused.
Posted Jun 28, 2025 - 17:58 UTC

Update

This incident has been resolved. We apologise for any inconvenience caused.
Posted Jun 28, 2025 - 17:58 UTC

Identified

We have identified a major outage with Orange Money service. This issue has been escalated to the mobile operator and we are following up closely to ensure a speedy resolution.
Posted Jun 28, 2025 - 16:51 UTC
This incident affected: Cameroon MNO Services (Orange Money).