Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 18, 2026 - 22:00 UTC
Scheduled
We would like to inform you that the MTN Mobile Money service on the Smobilpay platform will be unavailable from Saturday, 18th July 2026 at 10 :00 PM until Sunday, 19th July 2026 at 08 :00 AM (GMT+1), due to maintenance activities being carried out by MTN Cameroon on their platform.
Posted Jul 18, 2026 - 13:45 UTC
This scheduled maintenance affected: Cameroon MNO Services (MTN Mobile Money).