Performance degradation affecting CAMTEL DATA services.

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted May 08, 2025 - 07:28 UTC

Identified

We have identified instability in {CAMTEL DATA ) services. We have escalated this to the Service Provider for resolution.
Posted May 08, 2025 - 05:43 UTC
This incident affected: Cameroon MNO Services (Camtel Recharge/Top-up).