Performance degradation affecting CAMTEL Recharge/Topup and CAMTEL DATA services.

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 25, 2025 - 15:35 UTC

Identified

We have identified instability in { CAMTEL Recharge/Topup and CAMTEL DATA) services. We have escalated this to the Service Provider for resolution.
Posted Mar 25, 2025 - 14:24 UTC
This incident affected: Cameroon MNO Services (Camtel Recharge/Top-up).