Performance degradation affecting Camwater BIlls/Factures services.

Incident Report for Smobilpay

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 07:13 UTC

Identified

We have identified instability in { Camwater BIlls/Factures) services. We have escalated this to the Service Provider for resolution.
Posted Mar 19, 2025 - 15:04 UTC
This incident affected: Bill Payment (Camwater Bills).