Performance degradation affecting ENEO Bills/Postpaid

Incident Report for Smobilpay

Resolved

This incident has been resolved.
Posted 14 days ago. Mar 21, 2025 - 14:12 UTC

Identified

We have identified instability in ENEO Bills/Postpaid services. We have escalated this to the Service Provider for resolution
Posted 14 days ago. Mar 21, 2025 - 12:08 UTC
This incident affected: Bill Payment (ENEO Bills).