Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 19, 2026 - 07:55 UTC
Update
Scheduled maintenance still in progress. We will provide update as soon as necessary.
Posted Apr 19, 2026 - 07:54 UTC
Update
Due to ongoing maintenance activities at our partner MTN Cameroon, the following services remain temporarily unavailable. The maintenance has not yet been completed, and service restoration is still in progress. Affected services: MTN MoMo Cash‑in and Cash‑out MTN Recharge / Airtime Smobilpay account top‑up via MTN MoMo MTN Disbursements We will update the status page as soon as the maintenance is completed and services are fully restored. Thank you for your patience and understanding.
Posted Apr 19, 2026 - 07:37 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 18, 2026 - 22:00 UTC
Scheduled
Due to maintenance activities at our partner MTN Cameroon, the following services will be unavailable from Saturday 18 April at 10pm to Sunday 19 April at 8am: - MTN MoMo Cashin and Cashout - MTN Recharge/Airtime - Topup Smobilpay account via MTN MoMo - Disbursement MTN
Posted Apr 17, 2026 - 22:04 UTC
This scheduled maintenance affected: Cameroon MNO Services (MTN Mobile Money, MTN Recharge/Top-up, MTN Mobile Money : Collections, MTN Mobile Money : Disbursement).