Performance degradation affecting ENEO Bills/Postpaid Services

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 24, 2025 - 06:51 UTC

Identified

We have identified instability in { ENEO Bills/Postpaid) services. We have escalated this to the Service Provider for resolution.
Posted Mar 22, 2025 - 10:44 UTC
This incident affected: Bill Payment (ENEO Bills).