We are currently experiencing instability with our MTN MoMo Cash-In / Depot Service. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.
Posted Sep 17, 2026 - 15:40 UTC
Identified
We are currently experiencing instability with our MTN MoMo Cash-In / Depot Service. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.
Posted Sep 09, 2026 - 23:07 UTC
This incident affects: Cameroon MNO Services (MTN Mobile Money).