This is a quick update to inform you that we are still experiencing degraded performance in DSTV Service. We are closely following up on it with the Service Provider. We'll provide an update as soon as possible.
Posted Jul 27, 2026 - 07:27 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in DSTV Service. We are closely following up on it with the Service Provider. We'll provide an update as soon as possible.
Posted Jul 24, 2026 - 07:57 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in DSTV Service. We are closely following up on it with the Service Provider. We'll provide an update as soon as possible.
Posted Jul 20, 2026 - 08:05 UTC
Update
We are still experiencing instability with our DSTV services. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.
Posted Jul 08, 2026 - 06:59 UTC
Update
We are still experiencing instability with our DSTV services. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.
Posted Jul 06, 2026 - 10:19 UTC
Update
We are currently experiencing instability with our DSTV services. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.
Thank you for your patience.
Posted Jul 05, 2026 - 11:54 UTC
Update
We are still experiencing instability with our DSTV services. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.
Thank you for your patience.
Posted Jul 01, 2026 - 15:31 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in DSTV Service. We are closely following up on it with the Service Provider. We'll provide an update as soon as possible.
Posted Jun 30, 2026 - 17:08 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in DSTV Service. We are closely following up on it with the Service Provider. We'll provide an update as soon as possible.
Posted Jun 29, 2026 - 07:41 UTC
Update
Dear Valued Partner, Further to our previous communication, we would like to inform you that DSTV services are still experiencing instability. The matter remains under active review by the service provider, who continues to work towards a resolution. We sincerely appreciate your patience and understanding as we closely monitor the situation and await further updates. We will keep you informed of any significant developments. Kind regards, Smobilpay Team
Posted Jun 28, 2026 - 08:44 UTC
Update
Dear Valued Partner, Further to our previous communication, we would like to inform you that DSTV services are still experiencing instability. The matter remains under active review by the service provider, who continues to work towards a resolution. We sincerely appreciate your patience and understanding as we closely monitor the situation and await further updates. We will keep you informed of any significant developments. Kind regards, Smobilpay Team
Posted Jun 27, 2026 - 08:43 UTC
Update
We are currently experiencing instability with our DSTV services. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.
Thank you for your patience.
Posted Jun 25, 2026 - 09:55 UTC
Update
We are currently experiencing an outage of services provided by DSTV. This is impacting payments Our technical team has launched an immediate investigation to identify the root cause.
We sincerely apologize for the inconvenience and thank you for your patience.
Posted Jun 24, 2026 - 06:47 UTC
Identified
We are currently experiencing instability with our DSTV services. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.
Thank you for your patience.
Posted Jun 23, 2026 - 13:30 UTC
This incident affects: Cable TV Subscription (DSTV).