Performance Degradation Affecting CAMTEL Recharge/Airtime

Incident Report for Smobilpay

Resolved

This incident has been resolved.
Posted Sep 06, 2026 - 12:50 UTC

Identified

We are currently experiencing an outage of services provided by {Service Provider}. This is impacting payments
Our technical team has launched an immediate investigation to identify the root cause.

We sincerely apologize for the inconvenience and thank you for your patience.
Posted Sep 06, 2026 - 10:46 UTC
This incident affected: Cameroon MNO Services (Camtel Recharge/Top-up).