Performance degradation affecting Orange Airtime services.

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 26, 2025 - 14:55 UTC

Identified

We have identified instability in { Orange Airtime) services. We have escalated this to the Service Provider for resolution.
Posted Mar 25, 2025 - 15:36 UTC
This incident affected: Cameroon MNO Services (Orange Recharge/Airtime).