Performance degradation affecting Orange Money Services.

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Jun 25, 2025 - 11:37 UTC

Identified

We have identified instability in { Orange Money Collections) services. We have escalated this to the Service Provider for resolution.
Posted Jun 25, 2025 - 10:10 UTC
This incident affected: Cameroon MNO Services (Orange Money : Collections).