Performance degradation affecting Express Union Services

Incident Report for Smobilpay

Resolved

This incident has been resolved.
Posted May 19, 2025 - 10:31 UTC

Identified

We have identified instability in Express Union Services. We have escalated this to the Service Provider for resolution.
Posted May 17, 2025 - 18:14 UTC