Smobilpay Platform – Partial Outage (Update in Progress)

Incident Report for Smobilpay

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 08:21 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 08:06 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 05:55 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 05:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 05:52 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 05:52 UTC

Identified

Dear partners,

The Smobilpay platform update is still in progress, and some services such as Orange Mobile Money services ENEO Prepaid and CAMTEL remain impacted.

Operations and transactions for these services are currently unavailable. Our technical teams have identified the issue and are actively working to restore full service as soon as possible.

We will provide the next update within 1 hour as soon as there is significant progress.

We appreciate your patience and understanding.

Support Team
Posted Jun 11, 2026 - 05:45 UTC
This incident affects: Cable TV Subscription (Canal +, DSTV, StarTimes), Bill Payment (Camwater Bills, ENEO Bills), Maviance Platform (Smobilpay Payment Platform and APIs), Cameroon MNO Services (MTN Mobile Money, Orange Money, MTN Recharge/Top-up, Orange Recharge/Airtime, MTN Mobile Money : Collections, Orange Money : Collections, MTN Mobile Money : Disbursement, Orange Money : Disbursement, Camtel Recharge/Top-up), and SABC Payment.