The incident has been resolved. We apologise for the inconvenience.
Posted Jun 20, 2025 - 14:29 UTC
Identified
We have identified instability in { Orange Money Cash in / DEPOT and Orange Money Cash Out / RETRAIT) services. We have escalated this to the Service Provider for resolution.
Posted Jun 20, 2025 - 08:22 UTC
This incident affected: Cameroon MNO Services (Orange Money).