Performance degradation affecting Moov Tchad - Collections

Incident Report for Smobilpay

Update

This is a quick update to inform you that we are still experiencing degraded performance in Moov Tchad - Collection Service. We are closely following up on it with the Service Provider. We'll provide an update as soon as possible.
Posted Jul 27, 2026 - 07:28 UTC

Update

This is a quick update to inform you that we are still experiencing degraded performance in Moov Tchad - Collection Service. We are closely following up on it with the Service Provider. We'll provide an update as soon as possible.
Posted Jul 24, 2026 - 07:54 UTC

Identified

We have identified a major outage with Moov Tchad - Collections. This issue has been escalated to the mobile operator and we are following up closely to ensure a speedy resolution.
Posted Jul 22, 2026 - 17:38 UTC