Performance degradation affecting Orange Airtime Services.

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Apr 23, 2026 - 10:28 UTC

Update

This is a quick update to inform you that we are still experiencing degraded performance in our Orange Airtime Service. Orange is aware and actively working to identify the root cause. We’ll keep you informed as we learn more
Posted Apr 23, 2026 - 09:35 UTC

Identified

We are currently experiencing instability with our Orange Airtime services. The issue has been escalated to their team for resolution. We will keep you updated as soon as we receive more information.

Thank you for your patience.
Posted Apr 23, 2026 - 07:53 UTC
This incident affected: Cameroon MNO Services (Orange Recharge/Airtime).