Performance degradation affecting Orange services.

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Oct 05, 2025 - 16:53 UTC

Identified

We have identified a major outage with Orange services.. This issue has been escalated to the mobile operator and we are following up closely to ensure a speedy resolution.
Posted Oct 05, 2025 - 14:42 UTC
This incident affected: Cameroon MNO Services (Orange Money, Orange Recharge/Airtime, Orange Money : Collections, Orange Money : Disbursement).