Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2025 - 22:08 UTC
Scheduled
We would like to inform you that MTN Mobile Money services on the Smobilpay platform will be unavailable from 23:00 on March 17, 2025, to 05:00 on March 18, 2025 (GMT+1) due to scheduled maintenance by MTN Cameroon. Please note that this service interruption will also occur for the following two days during the same time period.
We will notify you as soon as the service is restored.
Posted Mar 17, 2025 - 22:03 UTC
This scheduled maintenance affected: Cameroon MNO Services (MTN Mobile Money, MTN Mobile Money : Collections, MTN Mobile Money : Disbursement).