Performance degradation affecting MTN MoMo CashIn services.

Incident Report for Smobilpay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted May 06, 2025 - 16:20 UTC

Identified

We have identified instability in { MTN momo CashIn) services. We have escalated this to the Service Provider for resolution.
Posted May 06, 2025 - 16:04 UTC
This incident affected: Cameroon MNO Services (MTN Mobile Money).