Performance degradation affecting MTN MoMo - Cash Collection services
Incident Report for Smobilpay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Nov 13, 2024 - 16:43 UTC
Identified
We have identified instability in MTN MoMo Cash - Out from Cash Collection services. We have escalated this to the Service Provider for resolution.
Posted Nov 13, 2024 - 15:58 UTC
This incident affected: Cameroon MNO Services (MTN Mobile Money : Collections).